WYRDYSM GAMES

Home of Battleships Forever
It is currently Thu Aug 21, 2014 4:13 pm

All times are UTC + 8 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: error on startup
PostPosted: Mon Sep 19, 2011 2:29 pm 
Offline
Admiral
Admiral
User avatar

Joined: Tue Feb 26, 2008 9:09 am
Posts: 1978
So I recently reinstalled windows XP and since then haven't been able to load the game. Shipmaker works fine. I get the following error when loading BSF: Failed to initialize BGM - Invalid device number.
Things I have tried:
-Restarting
-Reinstalling the game- from different download locations and installing in different directories.
-Running as administrator; not the primary that installed windows.
-deleting some of the .dlls as suggested in several of the help threads, though I think those were slightly different problems.
I've searched the forum a bit, but almost every reference I find for this involves Vista. I'm assuming its some default setting that got reset when I reinstalled and its been too long since the last time for me to remember. I've been running BSF on this computer almost as long as I've been playing it. I am having an issue updating my audio driver but I wouldn't have thought that would affect loading. Any advice is appreciated.


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Mon Sep 19, 2011 3:22 pm 
Offline
aka SilverWingedHerpaderp
User avatar

Joined: Wed Sep 26, 2007 8:51 pm
Posts: 3412
Location: Elsewhere
Well this is... weird. You said you've just reinstalled Windows XP. Have you installed Service Pack 3? Have you got all the up-to-date drivers and everything? I honestly don't have any clue what the problem is, I'm just tossing shit out there and trying to see what sticks.

I honestly have no idea how you might solve the problem if neither of those things work and all the other stuff you tried didn't work. Hopefully th15 or someone else who knows what the problem is will be able to help.

Also this thread is in the wrong board. :P Should've been in the Bug Reports thread, or the General Discussion board, as it does not pertain to Shipmaker or Shipmaking or helping with either.

_________________
Founder and Event Coordinator for the BSF Beauty Pageant. Founder of the Pseudo-Chainship Project. Admin. Games Master.
Quality Control Enforcer


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Mon Sep 19, 2011 3:28 pm 
Offline
Admiral
Admiral
User avatar

Joined: Tue Feb 26, 2008 9:09 am
Posts: 1978
Doh sorry I meant to post in General discussion but was apparently paying more attention to what I was writing than where. Feel free to move it if your able because I'll probably get more responses.The bug reports thread appears to be locked though unless I'm seeing the wrong one. As far as I know all the drivers are up to date but that does seem the most likely culprit so I will check again because obviously I'm not running on all cylinders today...


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Mon Sep 19, 2011 5:00 pm 
Offline
aka SilverWingedHerpaderp
User avatar

Joined: Wed Sep 26, 2007 8:51 pm
Posts: 3412
Location: Elsewhere
Thread moved. Hope you're able to get BSF working again, jwa.

_________________
Founder and Event Coordinator for the BSF Beauty Pageant. Founder of the Pseudo-Chainship Project. Admin. Games Master.
Quality Control Enforcer


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Mon Sep 19, 2011 7:32 pm 
Offline
FOOLISH SAMURAI
User avatar

Joined: Thu Sep 13, 2007 10:37 am
Posts: 4028
Location: UK
I have no idea.

Try setting the music volume in the config to 0, that might help.

_________________
  /l、
゙(゚、 。 7
 l、゙ ~ヽ
 じしf_, )ノ


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Tue Sep 20, 2011 4:30 am 
Offline
Admiral
Admiral
User avatar

Joined: Tue Feb 26, 2008 9:09 am
Posts: 1978
Interesting. I changed the config and no longer get the error message but the game loads the menu screen then freezes with no message. Thats further than I was before at least so thanks.


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Tue Sep 20, 2011 11:04 pm 
Offline
Vice Admiral
Vice Admiral

Joined: Mon Jan 21, 2008 4:34 am
Posts: 1270
Location: Halifax, Canada
Then it's probably due to the outdated audio driver. Or have you managed to update that?
If that's not the problem then if you haven't already done so you could try turning the various options like surfaces etc. off (either all at once or 1 at a time) and see if it helps.
Good luck, you're one of the few long-time members still here and still reliably building, it'd be a shame if you can't anymore.

_________________
My Random Very Old Ships, Fleets, and Links to Other Ships and Fleets
My (Not Particularly) New Ships
My New Encounters - C&C Wanted


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Sat Sep 24, 2011 4:12 am 
Offline
Administrator
User avatar

Joined: Sun May 13, 2007 12:01 am
Posts: 940
Yea seems like a problem with the sound system which is fairly odd. Changing the ini file like arca said should prevent the background music dll from being loaded but it makes no sense that it still freezes then. Care posting what sound card you're using? It's most likely onboard AC '97 or something like that.

_________________
Sean 'th15' Chan
Image


Top
 Profile  
 
 Post subject: Re: error on startup
PostPosted: Mon Oct 03, 2011 1:16 pm 
Offline
Admiral
Admiral
User avatar

Joined: Tue Feb 26, 2008 9:09 am
Posts: 1978
Seems to have been a driver issue. I couldn't get my sound card to show up on my system so it wasn't actually updating it even though the driver utility ran...Thanks for the help guys!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group