WYRDYSM GAMES

Home of Battleships Forever
It is currently Fri Nov 28, 2014 8:05 pm

All times are UTC + 8 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Nov 28, 2009 6:25 am 
Offline
Captain
Captain
User avatar

Joined: Mon Oct 05, 2009 10:00 am
Posts: 411
Location: Karona, Fantasinia
I'm currently experimenting with a "bulwark" type ship that can take a considerable beating and protect it's own weapons. As for the weapons, i've made some "casings" for them. However, i've tried many trigger combinations to no avail. What i've been trying to do is have a trigger open up the "casings" and the weapons underneath switch on, and have another trigger close down the "casings" and deactivate the weapons. So far, I can only activate the weapons, but not deactivate.

Any suggestions?

_________________
Got questions about ShipMaker? Look here!

Life happens.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 28, 2009 7:51 am 
Offline
Commander
Commander

Joined: Sat Feb 02, 2008 4:47 pm
Posts: 157
Could you upload the sb4 so we can see how you've got your triggers setup?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 28, 2009 12:04 pm 
Offline
Captain
Captain
User avatar

Joined: Mon Oct 05, 2009 10:00 am
Posts: 411
Location: Karona, Fantasinia
http://filesmelt.com/downloader/NP-10.rar

The turrets are underneath the circular sections.

_________________
Got questions about ShipMaker? Look here!

Life happens.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 28, 2009 3:34 pm 
Offline
Commander
Commander

Joined: Sat Feb 02, 2008 4:47 pm
Posts: 157
Weird. After trying a few things, I've gotten one to work properly. Next step is to get it working properly with the turret.


I needed to add an egg timer and 2-position switch in order for it to work properly. Your system had it such that you could enable/disable the actual weapons while the covers were moving. This could allow a weapon to be enabled with the covers closed or disabled with them open. My system fixes that.

Once I've got it working with the turret, I'll upload the finished sb4.


EDIT: had some problems with the turrets not working even after fixing the triggers. I found out that the turrets weren't setup right - something wrong with the parenting. I got one to work flawlessly after completely disassembling it and redoing the parenting. I have to do the same for the other three. Problem is, I forgot what I did exactly...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group