WYRDYSM GAMES

Home of Battleships Forever
It is currently Sat Oct 25, 2014 5:28 pm

All times are UTC + 8 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: launching problem
PostPosted: Wed Dec 01, 2010 9:50 pm 
Offline
Ensign
Ensign

Joined: Wed Dec 01, 2010 9:33 pm
Posts: 2
hello to all
I'm French and I use google translation to speak so sorry if it badly written

my problem is that:
I played a BSF on Vista but recently I bought windows7
I have to reinstall OSB with all possible versions but it gives me this error message when launching the game.


___________________________________________
Error in
Action number 1
of Other Event: Game Start
for object GUI_MainTitle:

Error Defining an external function.

Is anybody can help me?


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Thu Dec 02, 2010 1:55 am 
Offline
Tournamentator
Tournamentator

Joined: Mon Mar 08, 2010 5:14 am
Posts: 669
Location: UK
are you an administrator? if you aren't vista and 7 will block BSF's access to it's own programme files which messes it up. just install somewhere where you have access such as your documents folder and it should run

_________________
There is no OP, there is only more boosters...


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Thu Dec 02, 2010 3:24 am 
Offline
Ensign
Ensign

Joined: Wed Dec 01, 2010 9:33 pm
Posts: 2
thank you very much it works :wink:


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Sun Jan 16, 2011 7:04 pm 
Offline
Lieutenant, Junior Grade
Lieutenant, Junior Grade

Joined: Thu Nov 25, 2010 4:25 pm
Posts: 15
Location: Central Coast, Australia
vidboi wrote:
are you an administrator? if you aren't vista and 7 will block BSF's access to it's own programme files which messes it up. just install somewhere where you have access such as your documents folder and it should run

For some reason this error wasn't fixed by this method, anyone know any details as to what might cause this error apart from the usual 64-bit randomness that Vista and 7 create?

_________________
Why limit yourself to being just human?


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Sun Jan 16, 2011 7:22 pm 
Offline
Tournamentator
Tournamentator

Joined: Mon Mar 08, 2010 5:14 am
Posts: 669
Location: UK
where have you installed the game? you could try reinstalling it in your "my documents" folder, or even on a memory stick or something (i've run bsf off of a memory stick on a computer running with vista before :D)

_________________
There is no OP, there is only more boosters...


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Sun Jan 16, 2011 9:02 pm 
Offline
Captain
Captain
User avatar

Joined: Sat Dec 13, 2008 7:59 pm
Posts: 317
Location: Location,location,location.!
Look up "disabling User Account Control", then follow the steps and disable it, then try reinstalling.

_________________
Nothing is forever. It can't be. 'Cause everyone changes.
Image
Whether they want to or not, they need to change. Myself... Even you!


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Mon Jan 17, 2011 6:17 am 
Offline
Lieutenant, Junior Grade
Lieutenant, Junior Grade

Joined: Thu Nov 25, 2010 4:25 pm
Posts: 15
Location: Central Coast, Australia
Dunno why, but restarting my laptop fixed it. Must've been another program using the code...

_________________
Why limit yourself to being just human?


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Mon Jan 17, 2011 7:51 am 
Offline
FOOLISH SAMURAI
User avatar

Joined: Thu Sep 13, 2007 10:37 am
Posts: 4033
Location: UK
Shifter55 wrote:
Dunno why, but restarting my laptop fixed it. Must've been another program using the code...


1) That's not how programs work. :?

2) Did you put your laptop into sleep/hibernate/power-saving-type modes before restarting? I know BSF has a history of not getting along with those.

_________________
  /l、
゙(゚、 。 7
 l、゙ ~ヽ
 じしf_, )ノ


Top
 Profile  
 
 Post subject: Re: launching problem
PostPosted: Mon Jan 17, 2011 10:51 am 
Offline
Lieutenant, Junior Grade
Lieutenant, Junior Grade

Joined: Thu Nov 25, 2010 4:25 pm
Posts: 15
Location: Central Coast, Australia
Arcalane wrote:
2) Did you put your laptop into sleep/hibernate/power-saving-type modes before restarting? I know BSF has a history of not getting along with those.

I've had my laptop in sleep mode with BSF running and its worked fine and started up correctly afterwards.

Arcalane wrote:
1) That's not how programs work. :?

Sometimes a file that is being scanned by my anti-virus can't be opened as it is in use, I assumed that other programs do this as well. Just shows how much I know about programming. :oops:

_________________
Why limit yourself to being just human?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group