WYRDYSM GAMES

Home of Battleships Forever
It is currently Mon Jul 28, 2014 12:13 pm

All times are UTC + 8 hours




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Sun Oct 17, 2010 6:28 pm 
Offline
Lieutenant
Lieutenant
User avatar

Joined: Thu May 13, 2010 4:38 pm
Posts: 26
Location: Wouldn't you like to know
I have been facing a problem which I have been trying to fix for about 2 days with no success. The Problem is that the 2 Blaster turrets on the back and the Big ion cannons on the front remain fixed in one direction when Spawning. Basically If I spawn my ship facing right, it looks normal, but if I rotate it to face northwards, then the turrets remain facing East instead of turning to face enemies. Once this is fixed then I will upload it and a bunch of other ships I have. I have left the link and driver lines visible to help anyone who tries to help me.


Attachments:
SMscreen05.png
SMscreen05.png [ 52.28 KiB | Viewed 1708 times ]

_________________
Roses are RED,
Violets are BLU,
In Soviet Russia,
Sandvich eats you.

Gamertag: SpectreX027
Top
 Profile  
 
PostPosted: Sun Oct 17, 2010 6:40 pm 
Offline
aka SilverWingedHerpaderp
User avatar

Joined: Wed Sep 26, 2007 8:51 pm
Posts: 3411
Location: Elsewhere
... We can't fix the problem or tell what the problem is just from a picture, you know. :| That doesn't actually provide us with any information at all. As it is, the problem you described sounds like you either gave the weapons a large turning arc and 0 turning speed, or you set a section to be driven by a weapon that is parented to it. If you upload an .sb4 I can tell you exactly what the problem is and fix it, but as it is, if you ask for help with a problem like this in the future and expect posting a damn picture to be helpful in solving the problem, I'll lock the thread and ignore you. :)

_________________
Founder and Event Coordinator for the BSF Beauty Pageant. Founder of the Pseudo-Chainship Project. Admin. Games Master.
Quality Control Enforcer


Top
 Profile  
 
PostPosted: Tue Oct 19, 2010 7:27 pm 
Offline
Lieutenant
Lieutenant
User avatar

Joined: Thu May 13, 2010 4:38 pm
Posts: 26
Location: Wouldn't you like to know
Sorry... :( ... knew I missed something... You will need the mirv beta for this ship... And please do not kill me SWS for this error.


Attachments:
RFB-365 'Acclamation'.sb4 [42.89 KiB]
Downloaded 59 times

_________________
Roses are RED,
Violets are BLU,
In Soviet Russia,
Sandvich eats you.

Gamertag: SpectreX027
Top
 Profile  
 
PostPosted: Tue Oct 19, 2010 8:03 pm 
Offline
aka SilverWingedHerpaderp
User avatar

Joined: Wed Sep 26, 2007 8:51 pm
Posts: 3411
Location: Elsewhere
...

Your ship is a fucking mess. What the fuck. I can't even begin to express all the problems with this but you clearly have no fucking idea what you're doing. Your attempts at a turreted weapon apparently work by linking two weapons TO EACH OTHER (Here's a hint, that doesn't work), and then trying to set up the section they're parented to to rotate when those weapons acquire targets. THAT IS NOT HOW YOU DO IT. THAT IS SO FUCKING FAR FROM HOW YOU DO IT THAT I'M STILL TRYING TO WRAP MY BRAIN AROUND YOUR INEPTITUDE.

Let me put it this way, and I'll try to be as nice as I can. To fix this crap, I'd need to destroy most of it and rebuild it.

And on to problems with this ship that are unrelated with your horrible attempts at turreted weapons: Your attempts at engine glows aren't additive, resulting in them having black boxes around them. Several center pieces are off-centered and thus mirrored, you use SWA turret sprites on Shiny sections, you spam and repeat sections all over the place, and everything about it is generally awful.

Oh, and you had two sprites pointing towards incorrect directories.

I hate you. :?

That said, I will fix it all anyway and post up the fixed version so maybe you can learn from your goddamn mistakes. I will do that later, when I'm less frustrated with you.

_________________
Founder and Event Coordinator for the BSF Beauty Pageant. Founder of the Pseudo-Chainship Project. Admin. Games Master.
Quality Control Enforcer


Top
 Profile  
 
PostPosted: Tue Oct 19, 2010 8:38 pm 
Offline
Lieutenant
Lieutenant
User avatar

Joined: Thu May 13, 2010 4:38 pm
Posts: 26
Location: Wouldn't you like to know
Uhhhhhh.... blood pressure man... but anyway please forgive my failure at building ships and yeah I had absolutely no idea what I was doing with the turrets, I couldnt find any other turrets so thats why they look bad.... but please excuse my language but I did make this post just to be fucking insulted, I made it for help with turret rotation and shit that could be applied for future ships... and if you have a problem with my ship... well thats fine and I do accept your criticism... but please do not compare your epic GOD ships to my sad noob ships... but enough of my rant... sorry in advance if you have somehow been offended but I do not take well to being offended and I will keep your advice in mind... Thank you.

_________________
Roses are RED,
Violets are BLU,
In Soviet Russia,
Sandvich eats you.

Gamertag: SpectreX027


Top
 Profile  
 
PostPosted: Tue Oct 19, 2010 9:26 pm 
Offline
aka SilverWingedHerpaderp
User avatar

Joined: Wed Sep 26, 2007 8:51 pm
Posts: 3411
Location: Elsewhere
You will note that the only insult I actually used was calling you "inept", which is demonstrably true, so don't whine at me about being insulted, because you have no idea how insulting I can be when the mood comes upon me. :) I'm not comparing my ships to your ships. I'm comparing anyone's concept of good ships to yours. But you are a newbie, so most of these mistakes are... somewhat forgivable.

The inability to make proper turreted sections I do not think is forgivable. There are plenty of people who explained it out there. But since it seems you're too lazy to go through the forums and look for said explanations and guides, I'll give you a step-by-step instruction. With pictures. Because I'm feeling generous.

Let's start with these turrets of yours. These horrible, horrible, turrets that you did entirely wrong.

Here's what I'm starting with. An incoherent mess of triggers and linking and horribleness.
Image

So I clear up all that. I don't know what on earth you did, because I had to actually delete one of the weapons and replace it to get one of those arrows to disappear. All the triggers on the section are turned off. I've made the guns visible again. I'll set the alpha for them back to 0 once I've fixed this mess.
Image

The next step is easy enough. We take a gun with the exact same parameters as the two on the weapon, and we place it HERE. Note that it is not parented to the section it is meant to guide. It is parented to the section that the "turret" is parented to.
Image

Now, this weapon is just to guide the turret. We don't want it shooting. So we go to the ED2 Tab and set "Shooting" to "disabled".
Image

Then we link the two weapons on the "turret" to that main gun. Like so.
Image

Now if you've done it right, it should look like this:
Image

And finally, you select the turret section itself, the bit you want to get aimed about, right-click on the central gun, and select "Set Driver", like so.
Image

Now you set all the weapons to being alpha 0, and it looks like so:
Image

That's it. That's everything. That's all you need to do. No triggers required. What's important to remember is that the gun that aims everything CANNOT BE PARENTED TO WHAT IT IS MEANT TO BE AIMING. Otherwise shit will fuck up horribly. I hope this has been educational. If you'd still like me to fix everything up for you, I'll do that later. And I might even put up some more educational guides to explain some of the things that obviously you need explained.

_________________
Founder and Event Coordinator for the BSF Beauty Pageant. Founder of the Pseudo-Chainship Project. Admin. Games Master.
Quality Control Enforcer


Top
 Profile  
 
PostPosted: Wed Oct 20, 2010 6:59 pm 
Offline
Lieutenant
Lieutenant
User avatar

Joined: Thu May 13, 2010 4:38 pm
Posts: 26
Location: Wouldn't you like to know
Thank you a lot... now I am truly sorry for my previous rant because I had a very bad day when I posted it... anyway I really needed this to be explained in depth so thank you and also... this is merely a test ship... so yeah it wasn't meant to look good or incredibly detailed... I only built it just to experiment with turrets... but regardless, yes the ship did look shit and I acknowledge that and if you have any nice looking turrets that fit well with Shiny sections then please provide a link for it. And this is also an excellent guide so thank you.

_________________
Roses are RED,
Violets are BLU,
In Soviet Russia,
Sandvich eats you.

Gamertag: SpectreX027


Top
 Profile  
 
PostPosted: Thu Oct 21, 2010 2:32 pm 
Offline
FOOLISH SAMURAI
User avatar

Joined: Thu Sep 13, 2007 10:37 am
Posts: 4028
Location: UK
The trick is in the very turret you're using:

Build your own. Piece them together out of existing sections!

_________________
  /l、
゙(゚、 。 7
 l、゙ ~ヽ
 じしf_, )ノ


Top
 Profile  
 
PostPosted: Fri Oct 29, 2010 3:55 pm 
Offline
Lieutenant
Lieutenant
User avatar

Joined: Thu May 13, 2010 4:38 pm
Posts: 26
Location: Wouldn't you like to know
Thanks Arcalane for the help... I will upgrade this ship with a turret made out of individual sections

_________________
Roses are RED,
Violets are BLU,
In Soviet Russia,
Sandvich eats you.

Gamertag: SpectreX027


Top
 Profile  
 
PostPosted: Thu Dec 23, 2010 8:17 am 
Offline
Lieutenant Commander
Lieutenant Commander

Joined: Sat Oct 24, 2009 12:55 pm
Posts: 53
I also have a problem. My Weapon Platform uses two fusion beams to make its turret, right? Well, I have the weapon on the tip of the gun linked to the driving one, the driving one's ED2 "Shooting" is set to "disabled"... and yet the rear weapon is the only one that shoots. A little advice for a turret noob?


Attachments:
OWP-1.sb4 [5.29 KiB]
Downloaded 60 times
Top
 Profile  
 
PostPosted: Thu Dec 23, 2010 10:49 am 
Offline
FOOLISH SAMURAI
User avatar

Joined: Thu Sep 13, 2007 10:37 am
Posts: 4028
Location: UK
Everything seems to work fine for me. Try deleting the .shp and resaving it?

_________________
  /l、
゙(゚、 。 7
 l、゙ ~ヽ
 じしf_, )ノ


Top
 Profile  
 
PostPosted: Fri Dec 24, 2010 1:49 am 
Offline
Lieutenant Commander
Lieutenant Commander

Joined: Sat Oct 24, 2009 12:55 pm
Posts: 53
Now it works.

That seems to be premature; the blasted front gun, even when parented to the section above it, will not move with the barrel. As such... will not fire. At least the rear one isn't either.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group